Page 4 of 8

Ford's SS1

Posted: Thu May 03, 2018 12:24 pm
by Corky
I’d go poly on the F&R ARB mounts, and if the budget will stretch I’d do the same in the front drop links and wishbones.

Ford's SS1

Posted: Thu May 03, 2018 1:21 pm
by scimjim
front & rear ARB and front wishbones top and bottom.

Ford's SS1

Posted: Thu May 03, 2018 8:08 pm
by Ford
Thank you both ^^

Ford's SS1

Posted: Sun May 06, 2018 10:04 pm
by Ford
IMG_1374.JPG
1
IMG_1374.JPG (193.44 KiB) Viewed 1019 times
IMG_1376.JPG
2
IMG_1376.JPG (113.02 KiB) Viewed 1019 times
IMG_1379.JPG
3
IMG_1379.JPG (131.78 KiB) Viewed 1019 times
Hopefully have time to clean up the welds and paint tomorrow, then just need to touch up some spots on the chassis and reassemble rear end (minus ARB, waiting to see if I need any more before ordering some bushes from QRG)

Ford's SS1

Posted: Mon May 07, 2018 7:01 am
by scimjim
Also seam weld the hub mounting plate while it’s bare like that - they have been known to crack and separate on competition cars.

Ford's SS1

Posted: Tue May 15, 2018 6:15 pm
by Ford
Been checking over the wiring this afternoon, and got the headlights working, except the left headlight doesn't try to raise.
I've read Phil Wormald's headlight guide thoroughly and been round with a voltmeter, checked the motor contacts, diodes, relay, but can't find anything wrong.
I'm not even able to turn the motor by hand with the knob, so looks like it might be the motor itself?
Is it just three bolts holding the motor on to the mechanism? I've got spares, but hopefully be able to get this motor sorted on the workbench.

Ford's SS1

Posted: Tue May 15, 2018 6:25 pm
by scimjim
Is the manual knob not turning at all? If so, the motor is probably seized. 3 bolts plus the arm and electrics.

Ford's SS1

Posted: Wed May 16, 2018 10:36 pm
by Ford
Looked quite severe at first, but cleaned up well.
c79890af-8bae-40b5-a2b0-6ceee362335c[1].jpg
c79890af-8bae-40b5-a2b0-6ceee362335c[1].jpg (124.97 KiB) Viewed 875 times
Are there any tips for minimising chance of these motors having water ingress?

Ford's SS1

Posted: Thu May 17, 2018 7:30 pm
by Ford
Does anybody know how many amps the headlight lift motor circuit breaker is rated for? Mine is missing so temporarily replaced with a piece of 5 amp fuse wire.

Ford's SS1

Posted: Thu May 17, 2018 7:50 pm
by scimjim
Do you mean the little dashboard mounted switch with the red button?

Ford's SS1

Posted: Thu May 17, 2018 7:58 pm
by Ford
scimjim wrote:
Thu May 17, 2018 7:50 pm
Do you mean the little dashboard mounted switch with the red button?
That's it, yes.

Ford's SS1

Posted: Thu May 17, 2018 8:14 pm
by scimjim
It’s called a thermal overload switch in the handbook but it’s essentially a circuit breaker as you describe it. There’s no value given that I’ve ever seen but the fuse for the motors is 15A.

Ford's SS1

Posted: Thu May 17, 2018 8:15 pm
by scimjim
I’ve got a few spares, do you need one?

Ford's SS1

Posted: Thu May 17, 2018 8:20 pm
by Ford
I was going to order some of these off ebay (from China, but not in a hurry to get one) for £2.54. They're rated to trip at 10A which should be OK I think?

Ford's SS1

Posted: Mon May 21, 2018 10:25 pm
by Ford
IMG_20180518_122552.jpg
1
IMG_20180518_122552.jpg (197.02 KiB) Viewed 711 times
New aluminium pulley is on the way to replace this.
IMG_20180520_114638.jpg
2
IMG_20180520_114638.jpg (100.03 KiB) Viewed 711 times
The only sidelight/indicator lights I have were on the old bumper, and nuts rusted solid, so had to do this:
IMG_20180520_153013.jpg
3
IMG_20180520_153013.jpg (153.31 KiB) Viewed 711 times
Lenses cleaned up.
IMG_20180520_182232.jpg
4
IMG_20180520_182232.jpg (166.26 KiB) Viewed 711 times
I'll need to replace the ignition lock at some point, which will involve swapping the top part of steering column. Is it possible without removing the dash?
IMG_20180521_185612.jpg
5
IMG_20180521_185612.jpg (134.88 KiB) Viewed 711 times
Also considering swapping stalks to an older set without dim/dip.
IMG_20180521_185811.jpg
6
IMG_20180521_185811.jpg (166.44 KiB) Viewed 711 times
I've got a spare one of these rubber boots, what needs removing in order to swap it?
IMG_20180521_185840.jpg
7
IMG_20180521_185840.jpg (115.43 KiB) Viewed 711 times
Can anybody help identify these for me? White+blue wire with ring terminal, there is one on each side of the engine bay.
IMG_20180521_185910.jpg
8
IMG_20180521_185910.jpg (125.89 KiB) Viewed 711 times
Also not sure if there is meant to be anything else coming off the radiator fan on this wire?
IMG_20180521_190129.jpg
9
IMG_20180521_190129.jpg (176.05 KiB) Viewed 711 times