Page 1 of 1

Multi switch on my Middlebridge number 29

Posted: Mon Oct 30, 2017 8:26 am
by Felix02
Everything works but on the right switch (horn + turn signal + low + high beam) On the high beam it does not hold in place...Is something broken ? DO I Have to change the whole multi switch or do you have an advice to fix it?
Capture.JPG
Capture.JPG (49.2 KiB) Viewed 1994 times

Multi switch on my Middlebridge number 29

Posted: Mon Oct 30, 2017 8:40 am
by peter freeman
The only way you will know if there is something broken is to take it off and have a look. Before doing that check that the switch arm is not just coming into contact with the cowling preventing it from completing its full travel ( unit fixed too far down the column ). The unit is from a Vauxhall by the way - cannot remember which one but similar to the Viva.

Multi switch on my Middlebridge number 29

Posted: Mon Oct 30, 2017 9:42 am
by DARK STAR
This is what it looks like, some of the moving bits and even spring bits are plastic so fragile, others are metal.
But as Peter says .... :wink:

Multi switch on my Middlebridge number 29

Posted: Mon Oct 30, 2017 9:46 am
by philhoward
Won’t be the first one that had been fixed by moving it /the shroud a little bit if that is the problem.

Multi switch on my Middlebridge number 29

Posted: Mon Oct 30, 2017 5:22 pm
by Roger Pennington
Felix02 wrote:
Mon Oct 30, 2017 8:26 am
right switch (horn + turn signal + low + high beam) On the high beam it does not hold in place.
Apologies if this is teaching granny to suck eggs, but your description of the functions has missed one "flash". pull back towards the driver is flash (which doesn't lock) and push away from the driver is high beam (which should lock). I'd agree that one thing worth checking is that the shroud is allowing free movement of the stalk

Multi switch on my Middlebridge number 29

Posted: Mon Oct 30, 2017 9:07 pm
by Will Anderson
I'd agree with checking the shroud but if the part is broken and you have difficulty in finding another then the owner of MB58 has replaced the unit with one from a British Leyland Maestro, also used on the SS series, I am told. See the post about Curborough Scimfest on the Middlebridge Facebook page.

Multi switch on my Middlebridge number 29

Posted: Tue Oct 31, 2017 8:02 am
by Felix02
I Just saw the post on FB with the MB 58. Thanks for all your posts.

Up and down shrouds are out and the arm is free. The only pb is that it does not lock pushing it for highbeam. maybe a plastic part worn inside.

I think I will have to change my Multi switch as it seems difficult to repair it inside...

Multi switch on my Middlebridge number 29

Posted: Tue Oct 31, 2017 11:10 am
by Roger Pennington
Yes, that does sound as though it may be the detent mechanism inside that's worm. Those switches are always difficult to repair successfully, because of the small springs which tend to fly out as soon as they are dismantled. If you *do* decide to give it a try, then a handy hint is to dismantle it in a clear plastic bag, so that when the bits fly out, they can't go far. Putting it back together is another story though! It may be easier to find another (though they can be hard to find, and correspondingly pricey) or an alternative, as above.