do i have a piece missing? Speedo drive - resolved?

Discuss and exchange views and technical information about our cars.

Moderators: scimjim, philhoward, erikscimitardemon, Roger Pennington, Lukeyboy46

Tinker man
RSSOC Member
Posts: 349
Joined: Thu Feb 04, 2016 8:39 am
Location: Davenham Cheshire
Has thanked: 14 times
Been thanked: 15 times

do i have a piece missing? Speedo drive

Post by Tinker man » Wed Jun 13, 2018 7:08 pm

Hi Jim,

That is my guess not a fact. I don’t think I am being clear really in my issue. Yes the cable outer will fasten to that drive at the gearbox. But! The cable just pokes into the hole in the drive in the gearbox. The cable inner protrudes only 1/4 inch or so down the hole in the drive. It doesn’t engage with anything. So if I connect things as they are then the gearbox end of the cable (square drive ) just pokes into a hole that is 4 times bigger than the cable. This hole is threaded. Last picture just about shows the thread. So the gearbox drive will turn but not engage with the cable. The cable will just sit there. It’s like something is missing or the cable end is wrong. Sorry if my descriptions are rubbish.

Ian


If it is made of nuts and bolts I WILL take it apart..... going back together is a whole different ball game

User avatar
scimjim
RSSOC Member
Posts: 35650
Joined: Sun Oct 01, 2006 10:08 pm
Location: Gloucester
Has thanked: 113 times
Been thanked: 813 times

do i have a piece missing? Speedo drive

Post by scimjim » Wed Jun 13, 2018 7:47 pm

No, you’re right - there’s a bit missing that has a square hole to mate with the cable inner - it’s just that I never knew it was removable/screwed in. I’ll grt another picture when I’m back at the workshop tomorrow. I don’t think I have a spare though unfortunately.


Jim King

Current: SE5 (8Ball), TI SS1 (snotty), 1600 SS1 (G97), 1600 SS1 (C686CCR), 2.5TD SE5a (diesel 5a), 6 x random other SS1s.
Previous: SE5, 3 x SE5a, 2 x SE6a, 3 x SE6b, GTC, 2.9i GTC, 3 x 1600 SS1, 1300 SS1, Mk1 Ti Sabre, Mk1.5 CVH Sabre
Chief mechanic for: 1400 K series SS1 (Megan3), 1400 CVH EFi SS1 (Grawpy), Sabre/MX5 auto (The Flying Broomstick),
1300 SS1 (Number One) & Sarah's coupe.
CURE THE FAULT - NOT THE SYMPTOMS

Tinker man
RSSOC Member
Posts: 349
Joined: Thu Feb 04, 2016 8:39 am
Location: Davenham Cheshire
Has thanked: 14 times
Been thanked: 15 times

do i have a piece missing? Speedo drive

Post by Tinker man » Wed Jun 13, 2018 8:06 pm

Thanks for persevering with me Jim. Ok, at least I know what I need. If you have one to photograph removed I could make one up if I can’t buy one.

Maybe someone else on here has one. If I can get a picture of what I need then I could do a wanted ad if the usual suppliers don’t have anything.

At least I now know I am not going mad.

Cheers Jim. It’s not a real pint but the thought is there. :pint :pint :pint


If it is made of nuts and bolts I WILL take it apart..... going back together is a whole different ball game

gtcse8
RSSOC Member
Posts: 1333
Joined: Fri Apr 24, 2009 10:11 am
Location: Steeton, Yorkshire Dales
Has thanked: 11 times
Been thanked: 74 times

do i have a piece missing? Speedo drive

Post by gtcse8 » Wed Jun 13, 2018 8:38 pm

The THREAD inside the housing is there to help removal from the gearbox if a different ratio of drive gear is needed, Ford actually manufactured a screw in removal fitting for this purpose.

They ARE colour coded, Green, Red, Yellow etc for the ratio needed, the speedo INNER cable Square end fits inside the plastic teeth properly when the other end is clipped into the speedo head.

I have a few of these fixtures if the speedo is incorrect on fitting.


See the Beast on youtube under" RELIANT SCIMITAR CONVERSION LOL.,Se5,Se5a, Se6a, Two Se6b`s, GTC, SST 1800Ti & not a lot of sense

Tinker man
RSSOC Member
Posts: 349
Joined: Thu Feb 04, 2016 8:39 am
Location: Davenham Cheshire
Has thanked: 14 times
Been thanked: 15 times

do i have a piece missing? Speedo drive

Post by Tinker man » Wed Jun 13, 2018 9:11 pm

Thanks for that info. Makes some sense to aid removal. But I thought the Speedo cable was correctly fitted at the head. This only leaves me just over 1/4 inch to go into the drive gear hole. Nowhere near enough to reach inside the gearbox drive unit. Perhaps I have it wrong at the head.

Do you happen to know how much cable inner should protrude from the end of the cable to go into the drive in the gearbox ?

It would have to be considerably more than present. I won’t have time to try again until Friday now but any information is a help.

Can’t believe I am having this much trouble to be honest. Thought this would have been one of my easier jobs! :roll:

Thank you, ian


If it is made of nuts and bolts I WILL take it apart..... going back together is a whole different ball game

gtcse8
RSSOC Member
Posts: 1333
Joined: Fri Apr 24, 2009 10:11 am
Location: Steeton, Yorkshire Dales
Has thanked: 11 times
Been thanked: 74 times

do i have a piece missing? Speedo drive

Post by gtcse8 » Wed Jun 13, 2018 9:24 pm

I have a feeling you have been given a Manual speedo cable.

But I do seem to remember there was an adaptor supplied at some point.


See the Beast on youtube under" RELIANT SCIMITAR CONVERSION LOL.,Se5,Se5a, Se6a, Two Se6b`s, GTC, SST 1800Ti & not a lot of sense

Tinker man
RSSOC Member
Posts: 349
Joined: Thu Feb 04, 2016 8:39 am
Location: Davenham Cheshire
Has thanked: 14 times
Been thanked: 15 times

do i have a piece missing? Speedo drive

Post by Tinker man » Wed Jun 13, 2018 9:45 pm

That could well be the case. I will do some calls tomorrow.

I have to say you guys are a real help. I will get there in the end. I just wish I could do one job without mithering. :D

It’s fast becoming my personal helpline.

Cheers


If it is made of nuts and bolts I WILL take it apart..... going back together is a whole different ball game

Tinker man
RSSOC Member
Posts: 349
Joined: Thu Feb 04, 2016 8:39 am
Location: Davenham Cheshire
Has thanked: 14 times
Been thanked: 15 times

do i have a piece missing? Speedo drive - resolved?

Post by Tinker man » Fri Jun 15, 2018 4:56 pm

Hi. Hopefully all resolved.

Visit to GW. Thanks Matt.

The auto cable comes with end piece attached for the gearbox. Swap the drive piece and a new O ring. Also the gearbox clamp is a closed type put on the cable when manufactured. Who knew? Must have been the wrong one attached previously. Probably why it didn’t work.

Hopefully all sorted. Will fit this weekend. Just have to pull out the wrong new one and put this one in. Double jointed wrist time again. I now have a spare new manual Speedo cable🙄

Thanks for all the help.
image.jpg
Attached to cable
image.jpg (270.19 KiB) Viewed 305 times


If it is made of nuts and bolts I WILL take it apart..... going back together is a whole different ball game

Tinker man
RSSOC Member
Posts: 349
Joined: Thu Feb 04, 2016 8:39 am
Location: Davenham Cheshire
Has thanked: 14 times
Been thanked: 15 times

do i have a piece missing? Speedo drive - resolved?

Post by Tinker man » Fri Jun 15, 2018 4:57 pm

Gearbox clamp.
image.jpg
image.jpg (246.09 KiB) Viewed 304 times


If it is made of nuts and bolts I WILL take it apart..... going back together is a whole different ball game

Post Reply

Return to “General Technical Discussion”